[Mailman-Users] mailman upgrade failing

Mark Sapiro mark at msapiro.net
Fri Mar 4 23:26:59 CET 2011

Noah wrote:
>Mailman upgrade keeps failing on my ubuntu server and not clear why? 
>qrunner hangs every week so upgrading might be the right thing to do.

Which qrunner hangs? What if anything is logged in Mailman's error and
qrunner logs?

Caveat: I know virtually nothing about Debian packaging or apt-get.

>Preparing to replace mailman 1:2.1.9-9ubuntu1.2 (using 
>.../mailman_1%3a2.1.9-9ubuntu1.4_amd64.deb) ...
>  * Stopping Mailman master qrunner mailmanctl          No child with 
>pid: 11139
>[Errno 3] No such process
>Stale pid file removed.

The above seems normal and not an error if you stopped Mailman manually
before running apt-get.

>   [ OK ]
>dpkg: error processing 
>/var/cache/apt/archives/mailman_1%3a2.1.9-9ubuntu1.4_amd64.deb (--unpack):
>  subprocess pre-installation script returned error exit status 1
>No updates are necessary.
>Any clues what I can do to get apt-get upgrade to work?

The process appears to be saying that the package in
mailman_1:2.1.9-9ubuntu1.4_amd64.deb does not contain any updates to
the installed mailman 1:2.1.9-9ubuntu1.2 package. This seems
reasonable as the actual Mailman package version (2.1.9-9) is the
same. Only the os version/architecture are different.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list