[Mailman-Users] mailman upgrade failing

Stephen J. Turnbull stephen at xemacs.org
Tue Mar 8 06:30:48 CET 2011

Noah writes:

 > Mark:  Do you have any ideas about how to force apt-get to consider 
 > using the version with the proper OS/arch version?

This really isn't appropriate for this list, you should be asking at
Ubuntu or Debian.  Personally, I would recommend removing the distro's
package and installing from source.  While letting distros maintain
most of your software really rocks, for your mission-critical apps all
too often you will find that they have "security" or "bugfix" patches
or configuration settings that are really just squeaky wheel grease,
and that get in the way of people with slightly different needs or

That said, the obvious thing to try is removing (without purging) the
package, and then reinstalling.  Of course you should back up
/var/lib/mailman (or wherever your distro puts mailman data), any
locally built handlers etc in /usr/lib/mailman/Mailman/Handlers, and
/etc first.

 > Like can I change a version file to get this update to happen?

Try looking up "pinning" in the apt docs.  I know that *some* forcing
of versions can be done, but I don't do it so I don't know the details.

More information about the Mailman-Users mailing list