[Mailman-Users] Group mismatch

Mark Sapiro mark at msapiro.net
Fri Oct 14 05:09:36 CEST 2011

Mollatt Ntini wrote:
>I had actually set the gid=0 which is wheel's group ID in the Makefile. 
>I do not even have the group=mail on my system. I have tried tweaking 
>around according to that link, but still no joy. What do you think 
>should change?

I would do the following:

First, I would not use group wheel. It is too privileged. You could use
'mailman', or 'daemon' or some other non-priveleged group that seems

Assuming you choose mailman, rerun configure with
--with-mail-gid=mailman and make install.

Then in your Exim config in the definition of the mailman_transport
transport, put

  user              = mailman
  group             = mailman

or if you already have something like

  user              = MM_UID
  group             = MM_GID

find the definitions of these and make them


Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list