[Mailman-Users] Hello all - mailman down after power failure and hard shutdown

Tanstaafl tanstaafl at libertytrek.org
Sun Jun 9 14:49:01 CEST 2013

On 2013-06-08 7:13 PM, Mark Sapiro <mark at msapiro.net> wrote:
> So, the doesn't occur with a single message to a single list, but it
> occurs when Postfix receives six messages at once FROM the lists-all
> list. Also your deliveries to to=<validuser1 at media-brokers.com> et al
> are via the virtual transport which is apparently unaffected.

Hmm, so when a list only contains other lists as members, those will use 
postfix's local transport, but when the members are individuals (for 
final delivery), it uses virtual. Ok, that makes sense then.

>> Also the weirdness when a list member has their vacation enabled - they
>> get the original list message, but the vacation message gets stuck in
>> the queue with the error.

> Another case of multiple messages to be handled by the local transport.

Ok, yeah, I think you've nailed it... the problem is when more than one 
message at a time is passed to postfix/local...

>> I'm thinking of trying to reinstalling (this is gentoo, so that will be
>> easy) first mailman, then postfix... I'll probably try that tomorrow if
>> no other solution presents itself.

> If you reinstall Mailman without touching Postfix and that fixes this,
> I'll be incredibly surprised.

I think you're right, I'll do postfix first.

> All the evidence you've presented together with everything I know says
> this is a Postfix issue, not a Mailman issue. If I knew Postfix as well
> as I know Mailman, I could probably tell you how to fix this.

Wish I did... I did get a comment from Victor on the postfix list to 
check all of my aliases, so I ran newaliases but that didn't help. Is 
there anything else I can do to test the mailman aliases? Since the 
individual lists work - confirmed because I sent the mass email I've 
been trying to send since this happened to each individual list that is 
a member of the lists-all list, and those all worked fine.

I agree with you that this seems to be a postfix problem, but is it 
possible that some kind of corruption in a userb could cause these 
warnings? To recap, they are:

The first one from postfix/master only shows up rarely - 11 times since 
I got the system back up, and within 5 or 10 minutes (but usually with 5 
or 10 seconds) of postfix being restarted:

postfix/master[6406]: warning: master_wakeup_timer_event: service 
tlsmgr(private/tlsmgr): Resource temporarily unavailable

Then these (only when I try to send to my lists-all list):

warning: connect to transport private/local: Resource temporarily 
warning: connect to transport private/retry: Resource temporarily 

I do have backups of my mysql userdb, as well as all others (mailman 
aliases/dbs, etc), so I can replace any of these from backups if it will 
fix the problem.

Thanks again for your time and help Mark...


More information about the Mailman-Users mailing list