[Mailman-Users] Mailman installation does not work

Bob Lydiate livingsky at gmail.com
Wed Jul 6 13:38:46 EDT 2016

I am reinstalling Mailman after having to change servers. I am using Ubuntu
16.04, Apache, Postfix, Mailman. I have apache and postfix both working and
serving mail and web. I have installed and re-installed Mailman a couple of
times to try and get it working right and now have no idea what is creating
the problem that stops it from working. I have several issues that I can
identify, and I am sure there are several that I have missed.

Problem 1
When I run 'check_perms -f' it tells me that the permissions on
/var/lib/mailman/cron bad group (has:root, expected list) (fixing)
this problem is repeated with 9 other scripts. When I check the actual
directory '/var/lib/mailman' I find that these files are all links to
'/usr/lib/*; where the correct group is set.

When I try to access the web interface, I am asked if I want to open a file
called 'admin' instead of opening a webpage called admin.

when I run '/etc/init.d/mailman start' or the equivalent for postfix or
apache, I get no errors.

I did alter the config setup to have mydomain.ca rather than
lists.mydomain.ca, but that is the only change I made to the config as it
came through.

I have checked the archives and have searched out the issues that I
suspect, but have found nothing that worked to fix these issues.


More information about the Mailman-Users mailing list