[Mailman-Users] Mailman installation does not work

Mark Sapiro mark at msapiro.net
Thu Jul 7 12:02:50 EDT 2016

On 7/6/16 10:38 AM, Bob Lydiate wrote:
> Problem 1
> When I run 'check_perms -f' it tells me that the permissions on
> /var/lib/mailman/cron bad group (has:root, expected list) (fixing)
> this problem is repeated with 9 other scripts. When I check the actual
> directory '/var/lib/mailman' I find that these files are all links to
> '/usr/lib/*; where the correct group is set.

You can ignore the check_perms error. It comes about because the Debian
(and hence Ubuntu) package patches check_perms to use os.lstat rather
than os.stat and thus looks at the mode and group of the symlink instead
of the target. The mode and group of the symlink are irrelevant and
can't be changed anyway.

> When I try to access the web interface, I am asked if I want to open a file
> called 'admin' instead of opening a webpage called admin.

This is an issue with your Apache config. See

> when I run '/etc/init.d/mailman start' or the equivalent for postfix or
> apache, I get no errors.


> I did alter the config setup to have mydomain.ca rather than
> lists.mydomain.ca, but that is the only change I made to the config as it
> came through.

What exactly did you change?

> I have checked the archives and have searched out the issues that I
> suspect, but have found nothing that worked to fix these issues.

What exactly are your issues? What doesn't work? What do you do that
produces a result different from what you expect, and what is the result?

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list