[pypy-dev] pypy-0.7.0 is out!

Arthur Peters amp at singingwizard.org
Mon Aug 29 00:15:58 CEST 2005

I tried translating pypy on my AMD64 laptop and it translated fine,
compilation did finally run the machine out of ram.

The machine was somewhat usable during the transation as the python
process was only using ~700 of 784MB of RAM (everything constantly
swapping of course). It got a bit more rocky during the C code
generation when the usage slowly went up by another 50MB. But I quit
trying to code with it in the background and let it continue. After a
while I checked and it had started to compile this continued, very
slowly, for long while longer at one point the cc1 process was using
over 800MB.

The lesson here is that it isn't really posible to translate it on a
64-bit machine with a normal amount of RAM, yet. Also I got a bunch of
warnings from the C compiler: "warning: cast to pointer from integer of
different size". This sounds to my like the code assumes that the int
is the same size as the pointer and it isn't on my machine. And I
suspect the result would not have been runable because of it.

The end of the story is that I was running out of RAM and swap and I
tried to add a swap file and the kernel killed the cc1 process. BTW, The
machine has in excess of 900MB of swap and my gnome session only uses a
couple hundred MB, so the compilation must have use an /huge/ amount of
memory to overflow the well over 1GB of available VM.

After the cc1 process was killed I was able to switch back to the X vt
and the graph viewer window had poped up and seemed to work.

I figure you know or could have guessed this would happen, but I thought
I'd send a report. Hope it is useful.


PS: BTW, I'm willing to try it again if it would help. This time I will
kill everything unnessisary and use 2-3GB of swap ;-)

More information about the Pypy-dev mailing list