[pypy-dev] Tkinter-pypy not building on windows

Arnaud F pachalmars at gmail.com
Wed Jan 18 18:37:39 CET 2012

Still no luck.
I made sure that i am using the correct version of tcl/tk and tested the
compilation of tkinter with python27 and it worked.
With pypy, i still have to define WITH_THREAD (it's defined in pyconfig.h
for python27 but not in pypy-1.7); I also had to modify the setup.py since
i used tcl/tk 8.5 (and the libs do not have the dot in windows : tcl85 and
Now I get missing libs error from the linker :

LINK : fatal error LNK1181: cannot open input file 'X11.lib'
LINK : fatal error LNK1181: cannot open input file 'python27.lib'

if i try to remove X11 from the librairies in setup.py and add a path to
python27.lib, i get a lot of unresolved external symbols


2012/1/17 Amaury Forgeot d'Arc <amauryfa at gmail.com>

> Hi,
> 2012/1/17 Arnaud F <pachalmars at gmail.com>
>> When trying to build tkinter from source, i get the following errors :
>   [...]
>> src/_tkinter.c(3133) : error C2065: 'tcl_lock' : undeclared identifier
> Which version of tcl are you using? Are you sure it was compiled with
> threads?
> There is a comment about this at the beginning of _tkinter.c:
> /* If Tcl is compiled for threads, we must also define TCL_THREAD. We
> define
>    it always; if Tcl is not threaded, the thread functions in
>    Tcl are empty.  */
> But compilation with a thread-less TCL is probably not so well supported.
> --
> Amaury Forgeot d'Arc
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/pypy-dev/attachments/20120118/86d20155/attachment.html>

More information about the pypy-dev mailing list