[pypy-dev] "import signal" fails when running PyPy interpreted

Stefan Behnel stefan_ml at behnel.de
Sun Mar 11 18:34:39 CET 2012

Maciej Fijalkowski, 11.03.2012 17:30:
> On Sun, Mar 11, 2012 at 9:27 AM, Stefan Behnel wrote:
>> I get an ImportError when trying to import the "signal" module in an
>> interpreted PyPy (latest source checkout):
>> """
>> python pypy/bin/py.py  -c 'import signal'
>> [...]
>> Traceback (application-level):
>>  File "<string>", line 1 in <module>
>> ImportError: No module named signal
>> """
>> Any ideas what's broken here?
>> I noticed this when trying to run a test from Cython's test suite in an
>> interpreted PyPy, and unittest failed to "import signal".
> run with --allworkingmodules or with --withmod-signal, otherwise it
> does not come with any modules.

Ok, that got me past the error above. The next one (after a couple of
minutes) is this:

Traceback (application-level):
  File "runtests.py", line 8 in <module>
    import shutil
RuntimeError: not holding the import lock

It keeps running after that, but then the test runs fail with the same
error. I tried running it in CPython and PyPy, same error in both, which
hints at a PyPy bug.

Anyway, given that it takes more than 10 minutes to get the test runner to
the point that it prints what tests it is going to run, and then another
lunchtime to actually run even one of them, I find it totally infeasible to
debug anything with this setup. Guess I'll just resign and let others do
that job.


More information about the pypy-dev mailing list