[ANNOUNCE] PyGobject 2.21.1 - unstable

Gian Mario Tagliaretti gianmt at gnome.org
Sat Jan 2 23:02:11 CET 2010

I am pleased to announce version 2.21.1 of the Python bindings for GObject.

The new release is available from ftp.gnome.org as and its mirrors
as soon as its synced correctly:


What's new since PyGObject 2.21.0?
        - Wrap gio.Volume.eject_with_operation (Gian Mario)
        - Wrap gio.Mount.eject_with_operation (Gian Mario)
        - Wrap gio.Mount.unmount_mountable_with_operation (Gian Mario)
        - Wrap File.unmount_mountable_with_operation (Gian Mario)
        - Wrap gio.File.stop_mountable (Gian Mario)
        - Wrap gio.File.start_mountable (Gian Mario)
        - Wrap gio.File.replace_readwrite_async (Gian Mario)
        - Wrap gio.File.poll_mountable (Gian Mario)
        - Wrap gio.File.open_readwrite_async (Gian Mario)
        - Wrap gio.File.eject_mountable_with_operation (Gian Mario)
        - Wrap gio.File.create_readwrite_async (Gian Mario)
        - Wrap gio.Drive.stop (Gian Mario)
        - Wrap gio.Drive.start (Gian Mario)
        - Wrap gio.SocketListener.accept_socket_async|finish (Gian Mario)
        - Wrap gio.SocketListener.accept_finish (Gian Mario)
        - Wrap gio.SocketListener.accept_async (Gian Mario)
        - Wrap gio.SocketListener.accept_socket (Gian Mario)
        - Wrap gio.SocketListener.accept (Gian Mario)
        - Make cancellable optional in gio.SocketClient.connect_to_host
          (Gian Mario)
        - Wrap gio.SocketListener.add_address (Gian Mario)
        - Wrap gio.SocketClient.connect_to_service_async (Gian Mario)
        - Wrap gio.SocketClient.connect_to_host_async (Gian Mario)
        - Wrap gio.SocketClient.connect_async (Gian Mario)
        - Wrap gio.SocketAddressEnumerator.next_async (Gian Mario)
        - Add a missing object gio.InetSocketAddress new in GIO 2.22
          (Gian Mario)
        - Make cancellable optional for gio.SocketAddressEnumerator.next
          (Gian Mario)
        - Wrap gio.Socket.condition_wait (Gian Mario)
        - Wrap gio.Socket.condition_check (Gian Mario)
        - Wrap gio.Resolver.lookup_service_finish (Gian Mario)
        - Wrap gio.Resolver.lookup_service_async (Gian Mario)
        - Wrap gio.Resolver.lookup_service (Gian Mario)
        - Wrap gio.Resolver.lookup_by_address_async (Gian Mario)
        - Wrap gio.Resolver.lookup_by_name_finish (Gian Mario)
        - Wrap gio.Drive.eject_with_data (Gian Mario)
        - Deprecate old gio.Drive methods (Gian Mario)
        - Wrap gio.Resolver.lookup_by_name (Gian Mario)
        - Make cancellable optional in gio.Resolver.lookup_by_address
          (Gian Mario)
        - Strip g_ prefix for many other functions (Gian Mario)
        - Strip g_ prefix from InetAddress functions (Gian Mario)
        - Fix function name gio.resolver_get_default (Gian Mario)
        - Wrap gio.FileIOStream.query_info_async (Gian Mario)
        - Register enums and flags in PyGI if needed (Tomeu Vizoso, #603534)
        - Wrap gio.IOStream.close_async (Gian Mario)
        - Make cancellable optional in GFile.create_readwrite (Gian Mario)
        - Remove a duplicate entry in gio.defs (Gian Mario)
        - Wrap gio.FileInfo.set_modification_time (Gian Mario)
        - Wrap gio.EmblemedIcon.get_emblems (Gian Mario)
        - Update Enums and Flags with new API (Gian Mario)
        - Fix handling of uchar in pyg_value_from_pyobject (Bastian Winkler)


GObject is a object system library used by GTK+ and GStreamer.

PyGObject provides a convenient wrapper for the GObject library for use
in Python programs, and takes care of many of the boring details such as
managing memory and type casting.  When combined with PyGTK, PyORBit and
gnome-python, it can be used to write full featured Gnome applications.

Like the GObject library itself PyGObject is licensed under the
GNU LGPL, so is suitable for use in both free software and proprietary
applications.  It is already in use in many applications ranging
from small single purpose scripts up to large full
featured applications.

PyGObject requires glib >= 2.22.4 and Python >= 2.3.5 to build.
GIO bindings require glib >= 2.22.4.

Please remember that this is an unstable release and shouldn't be used
in production.

Gian Mario Tagliaretti
GNOME Foundation member
gianmt at gnome.org

More information about the Python-announce-list mailing list