[Python-Dev] Berkeley DB

Andrew Kuchling akuchlin@mems-exchange.org
Tue, 25 Jul 2000 12:03:19 -0400

On Tue, Jul 25, 2000 at 11:56:05AM -0400, Fred L. Drake, Jr. wrote:
>module.  The existing bsddb module *is* the public interface; if
>db_wrap is a direct replacment, it should be called bsddb instead of

It's not; in fact, db_wrap.c is SWIG-generated code while the old
bsddb module was a hand-written extension.  Is it OK to add a
SWIG-generated module to the core?  (I have an irrational dislike
SWIG's trick of encoding pointers as strings, because it provides a
way to deliberately engineer core dumps; it's just sort of