[Python-Dev] Do we need to support Tcl/Tk versions before 8.0?

Guido van Rossum guido@python.org
Mon, 27 Mar 2000 15:43:06 -0500

The _tkinter.c source code is littered with #ifdefs that mostly center
around distinguishing between Tcl/Tk 8.0 and older versions.  The
two pre-8.0 version supported seem to be 7.5/4.1 and 7.6/4.2.

Would it be reasonable to assume that everybody is using at least
Tcl/Tk version 8.0?  This would simplify the code somewhat.

Or should I ask this in a larger forum?

--Guido van Rossum (home page: http://www.python.org/~guido/)