[Python-Dev] Do we need to support Tcl/Tk versions before 8.0?

Fred L. Drake, Jr. fdrake@acm.org
Mon, 27 Mar 2000 15:59:04 -0500 (EST)

Guido van Rossum writes:
 > The _tkinter.c source code is littered with #ifdefs that mostly center
 > around distinguishing between Tcl/Tk 8.0 and older versions.  The
 > two pre-8.0 version supported seem to be 7.5/4.1 and 7.6/4.2.
 > Would it be reasonable to assume that everybody is using at least
 > Tcl/Tk version 8.0?  This would simplify the code somewhat.

  Simplify!  It's more important that the latest versions are
supported than pre-8.0 versions.


Fred L. Drake, Jr.	  <fdrake at acm.org>
Corporation for National Research Initiatives