[Python-Dev] Do we need to support Tcl/Tk versions before 8.0?

Moshe Zadka Moshe Zadka <mzadka@geocities.com>
Tue, 28 Mar 2000 07:47:13 +0200 (IST)

On Mon, 27 Mar 2000, Guido van Rossum wrote:

> The _tkinter.c source code is littered with #ifdefs that mostly center
> around distinguishing between Tcl/Tk 8.0 and older versions.  The
> two pre-8.0 version supported seem to be 7.5/4.1 and 7.6/4.2.
> Would it be reasonable to assume that everybody is using at least
> Tcl/Tk version 8.0?  This would simplify the code somewhat.

I want to ask a different question: when is Python going to officially
support Tcl/Tk v8.2/8.3? I'd really like for this to happen, as I hate
having several libraries of Tcl/Tk on my machine.

(I assume you know the joke about Jews always answering a question 
with a question <wink>)
Moshe Zadka <mzadka@geocities.com>. 
http://www.linux.org.il -- we put the penguin in .com