[Python-Dev] PEP 208 comment
Sat, 6 Jan 2001 13:52:19 +0100
On Sat, Jan 06, 2001 at 11:06:49AM +0100, Martin v. Loewis wrote:
> Currently, it is called Py_TPFLAGS_NEWSTYLENUMBER. IMHO, nothing in a
> program should be called "new". The flag will still be there five
> years from now, but it won't be new anymore. Also, while the flag
> indicates that style of the numbers is new, it does not say what it
> does. So I propose to rename it; if nobody finds a better name, I
> propose to call it Py_TPFLAGS_UNCOERCED.
Wrong name. The TPFLAGs only indicate whether a struct is large enough to
contain a particular member, not whether that member is going to contain or
do anything. 'Py_TPFLAGS_HASCOERCE' or some such would seem more appropriate
Thomas Wouters <firstname.lastname@example.org>
Hi! I'm a .signature virus! copy me into your .signature file to help me spread!