[Python-Dev] Re: [Python-checkins] python/dist/src/Misc NEWS,1.542,1.543

Andrew Kuchling akuchlin@mems-exchange.org
Tue, 26 Nov 2002 07:40:25 -0500

On Tue, Nov 26, 2002 at 01:28:07AM -0800, loewis@users.sourceforge.net wrote:
>+ - _tkinter now returns Tcl objects, instead of strings. Objects which
>+   have Python equivalents are converted to Python objects, other objects
>+   are wrapped. This can be configured through the wantobjects method,
>+   or Tkinter.want_objects.

Will it be confusing to have the method be named wantobjects but the
module variable named want_objects?  (Glancing at the C code, it seems
to use only want_objects as a variable name, so the method name is the only 
inconsistent name.)

--amk                                                             (www.amk.ca)
EDGAR: The worst is not, so long as we can say "This is the worst."
      -- _King Lear_, IV, i