[Python-Dev] Building 2.1.3 on RH9

Dennis Allison allison at sumeru.stanford.EDU
Wed Aug 13 13:22:33 EDT 2003

Skip --

I love the 2.3 release, but I need the 2.1.3 engine for Zope.
Unfortunately, Zope is locked into 2.1.3.  Apoparently this is because of
incompatibilities with old vs. new classes, etc. etc.  2.2 and later is
unsupported.  All the docs say NO! but rumor has it that it works.

RH9 seems to have introduced all sorts of grubby stuff into the mix
including big changes in SSL and a threads library which breaks a lot of
things. It's frustrating to see Zope come up and just stop....

I'll try running with 2.2 and/or 2.3 to see if they work--then I guess
I'll have to reinstall RH7.3 which I know is stable.... 

I'll file a bug report 

Thanks.  -dra

On Wed, 13 Aug 2003, Skip Montanaro wrote:

>     Dennis> Seems to be broken -- at least _socket does not build correctly
>     Dennis> because of openssl changes.  (Arggh... )
>     Dennis> Where should this be reported?
> Well, presuming it will be fixed, the correct place to report it is on the
> Bugs page at
>     http://sourceforge.net/projects/python/
> However, the 2.1 series is getting to be pretty ancient history.  Even the
> Python Business Forum, when scouting around for a "stable" version of Python
> to use as py-in-a-tie chose 2.2.x.  There is almost certainly not going to
> be a 2.1.4 (unless you volunteer to be the release manager).  2.3 was
> released a couple weeks ago.
> You should probably consider upgrading to 2.3 (or at least 2.2.3).  If
> that's not possible, you might want to look at the _socket code in 2.2.3 or
> 2.3 for hints about how you can get the 2.1.3 version to compile.
> Skip

More information about the Python-Dev mailing list