[Python-Dev] Berkeley breakage

Tim Peters tim at zope.com
Mon Aug 18 12:57:14 EDT 2003

Over in the spambayes project, we get reports of database corruption from
people using Sleepycat bsddb.  The most recent comment on a bug report is


Date: 2003-08-18 04:09
Sender: fufsource

i did some experimenting with various bsddb3 versions:
  - with db-3.3.11 the python segfaults and core is dumped
  - with db-3.2.9 the database is corrupted
  - with db-4.1.25 everything works as it should (no db corruption)

spambayes makes elementary use of a Berkeley DB, just accessing via the dict
interface -- inserts, deletes and lookups, but no cursors, no transactions,
nothing "fancy".

I don't have time to dig into this, but assuming the report is correct, how
can we "encourage" Unix weenies to use db-4.1.25?  (On Windows, db-4.1.25 is
shipped with the installer.)  If the problems with older versions are so
severe, maybe the Python wrapper should do a version check and refuse to run
if it finds an old version?

More information about the Python-Dev mailing list