Mon, 17 Mar 2003 09:02:02 -0500
> Where was this agreed upon?
Perhaps I overstepped. It's been on my todo list for a
couple of months and didn't seem to be even slightly
> __iter__ returning self doesn't sound very generic to me,
> so at the very least the name should be changed IMO.
Thomas suggested PyObject_GetSelfIter, PyObject_GenericSelfIter,
or PyObject_SelfIter. Consistent with the other tp_slot fillers, I
> Also, adding a standard API for a helper function this
> trivial doesn't really make sense to me.
This identical code was duplicated in a dozen different
modules in the same context. It comes up when writing
most iterators and needed to be factored out.