Mon, 17 Mar 2003 09:41:01 -0500
> > __iter__ returning self doesn't sound very generic to me,
> > so at the very least the name should be changed IMO.
> Thomas suggested PyObject_GetSelfIter, PyObject_GenericSelfIter,
> or PyObject_SelfIter. Consistent with the other tp_slot fillers, I
> suggest PyObject_GenericIter.
A couple of other thoughts. While Thomas found the "getiter" part
of the name to be unintuitive, the type of the slot is named (getiterfunc)
and most of the replaced functions had names like dictiter_getiter,
enum_getiter, iter_getiter, listiter_getiter, xreadlines_getiter ...
So, my first preference is the name in the subject line.