copysort patch, was RE: [Python-Dev] inline sort option

Brett C. bac at OCF.Berkeley.EDU
Sat Oct 18 02:07:26 EDT 2003

Aahz wrote:

> On Fri, Oct 17, 2003, Guido van Rossum wrote:
>>>FWIW, I've posted a patch to implement list.copysort() that
>>>includes a news announcement, docs, and unittests:
>>Despite my suggesting a better name, I'm not in favor of this (let's
>>say -0).
> I'm actually -1, particularly with your clear argument; I just didn't
> like your suggestion of l.sorted().

I'm -1 as well.  Lists do not need to grow a method for something that 
only replaces two lines of code that are not tricky in any form of the word.


More information about the Python-Dev mailing list