[Python-Dev] Python 2.4 extensions require VC 7.1?

Giovanni Bajo rasky at develer.com
Fri Jun 16 21:12:29 CEST 2006

Bill Janssen <janssen at parc.com> wrote:

>> I'm trying to build a Python extension, and Python 2.4 insists on
>> the MS
>> Visual C++ compiler version 7.1, which is included with the MS VC++
>> 2003
>> toolkit.  This toolkit is no longer available for download from
>> Microsoft (superseded by the 2005 version), so I'm stuck.
> This seems sub-optimal.  I'm afraid I don't follow the Windows track
> closely; has this been fixed for 2.5, or should it be reported as a
> bug?

It was discussed before, and the agreement was to use VS 2003 for another cycle
(i.e. 2.5). But the fact that VS 2003 is no longer available for download is an
important fact, and we might want to rediscuss the issue.

Giovanni Bajo

More information about the Python-Dev mailing list