[Python-Dev] pysqlite for 2.5?
janssen at parc.com
Thu Mar 30 01:36:34 CEST 2006
Charles Cabazon writes:
> > On the package naming issue: using "em" for "email" would be wrong,
> Eh, that should be "import electronic_mail", then. And
> "import simple_mail_transport_protocol_lib".
> > just as "db" for "database" would be wrong.
> People who are familiar with Extensible Markup Language abbreviate it "xml".
> People who are familiar with electronic mail abbreviate it "email". And
> people who are familiar with the concept of a database abbreviate it "db".
> Why are two right for the stdlib (sorry, "standard library" :), and the other
Wow, what a world of black-and-white people we've got :-).
Here's what I was thinking:
"db" and "em" are too short to be useful context-free abbreviations,
because there's too much chance of either conflicting with variable
names in existing programs, or being confused with some other meaning
for those two letters.
"email" and "xml", on the other hand, have enough real-world emphasis
to be suitable. "stdlib" might or might not be OK ("python_stdlib"
might be better, or "pystdlib"); "py" surely isn't.
More information about the Python-Dev