[Python-Dev] Path object design

Talin talin at acm.org
Fri Nov 3 07:35:11 CET 2006

Steve Holden wrote:
> Greg Ewing wrote:
>> Mike Orr wrote:
>> Having said that, I can see there could be an
>> element of confusion in calling it "join".
> Good point. "relativise" might be appropriate, though something shorter 
> would be better.
> regards
>   Steve

The term used in many languages for this sort of operation is "combine". 
(See .Net System.IO.Path for an example.) I kind of like the term - it 
implies that you are mixing two paths together, but it doesn't imply 
that the combination will be additive.

- Talin

More information about the Python-Dev mailing list