[Python-Dev] PEP: Consolidating names and classes in the `unittest` module (updated 2008-07-15)

Antoine Pitrou solipsis at pitrou.net
Tue Jul 15 19:55:00 CEST 2008

> So far I have "precedent and tradition" and "positive admonition looks
> better" in support of preferring the 'assert*' names. Are there any
> others?

Avoiding double negatives.
(and don't tell me "fail" is not a negative word, because you just used
the phrase "positive admonition" to refer to the assert* variants, which
implies quite clearly that the fail* variants are on the negative
side ;-))



More information about the Python-Dev mailing list