[Python-Dev] Determine minimum required version for a script

Gerhard Häring gh at ghaering.de
Wed Oct 1 16:50:18 CEST 2008

techtonik wrote:
> Can somebody remind how to check script compatibility with old Python versions?
> I can remember PHP_CompatInfo class for PHP that parses a script or directory to
> find out the minimum version and extensions required for them to run,
> and I wonder
> if there was anything like this for Python?

You posted on the *python-dev* mailing list.

On this list the key *Python developers* discuss the future of the 
language and its implementation. Topics include Python design issues, 
release mechanics, and maintenance of existing releases.

Please, do not post general Python questions to this list! For help with 
Python please use the mailing list python-list at python.org or the 
newsgroup comp.lang.python. Messages are routed between the two. so 
they're basically the same thing.

-- Gerhard

More information about the Python-Dev mailing list