[Python-Dev] PEP 418: rename time.monotonic() to time.steady()?
victor.stinner at gmail.com
Tue Apr 3 23:14:15 CEST 2012
> Wait, what?
> I already thought we, several days ago, decided that "steady" was a
> *terrible* name, and that monotonic should *not* fall back to the
> system clock.
Copy of a more recent Guido's email:
"Anyway, the more I think about it, the more I believe these functions
should have very loose guarantees, and instead just cater to common
use cases -- availability of a timer with minimal fuss is usually more
important than the guarantees. So forget the idea about one version
that falls back to time.time() and another that doesn't -- just always
fall back to time.time(), which is (almost) always better than
Then we can design a separate inquiry API (doesn't have to be complex
as long as it's extensible -- a dict or object with a few predefined
keys or attributes sounds good enough) for apps that want to know more
about how the timer they're using is actually implemented."
I added time.get_clock_info() so the user can check if the clock is
monotonic or not.
More information about the Python-Dev