[Python-Dev] time.clock_info() field names
mark at hotpy.org
Mon Apr 30 10:26:14 CEST 2012
Benjamin Peterson wrote:
> 2012/4/29 Jim J. Jewett <jimjjewett at gmail.com>:
>> In http://mail.python.org/pipermail/python-dev/2012-April/119134.html
>> Benjamin Peterson wrote:
>>> I see PEP 418 gives time.clock_info() two boolean fields named
>>> "is_monotonic" and "is_adjusted". I think the "is_" is unnecessary and
>>> a bit ugly, and they could just be renamed "monotonic" and "adjusted".
>> I agree with monotonic, but I think it should be "adjustable".
> I don't really care, but I think "adjusted" is fine. As in "this clock
> is adjusted (occasionally)".
monotonic is an adjective, whereas adjusted is (part of) a verb. I think
both should be adjectives. Does "adjusted" mean that it has been
adjusted, that it can be adjusted or it will be adjusted?
More information about the Python-Dev