[Python-Dev] please back out changeset f903cf864191 before alpha-2
eliben at gmail.com
Mon Aug 26 20:38:33 CEST 2013
On Mon, Aug 26, 2013 at 10:40 AM, Paul Moore <p.f.moore at gmail.com> wrote:
> On 26 August 2013 17:40, Eli Bendersky <eliben at gmail.com> wrote:
>> Yes, exactly :-) "Incremental", though, seems to support the conjecture
>> that it's the input. Which is true, but, since XMLParser is also
>> "incremental" in this sense, slightly confusing.
> As a data point, until you explained the difference between the two
> classes earlier in this thread, I too had been completely confused as both
> the existing and the new classes are "incremental" (on the input side -
> that's what I interpret "incremental" as meaning). It never even occurred
> to me that the difference was in the *output* side. Maybe "NonBlocking"
> would imply that to me. Or maybe "Generator". But regardless, I think the
> changes you've made sound good, and I'm certainly less concerned with the
> new version(as someone who will likely never use the new API, and therefore
> doesn't really have a vote).
Thanks for the data point; it is useful.
> How about StreamParser?
The problem with StreamParser is similar to IncrementalParser. "Stream"
carries the impression that it refers to the input. But the input of ET
parsers is *always* streaming, in a way (the feed/close interface). I want
a name that conveys that the *output* is also
nonblocking/streaming/yielding/generating/etc. Therefore Nonblocking (I'll
let better English experts to decide whether B should be capitalized)
sounds better to me, because it helps convey that both sides of the parser
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Python-Dev