[Python-Dev] PEP 447: add type.__locallookup__

Yury Selivanov yselivanov.ml at gmail.com
Mon Sep 9 22:01:47 CEST 2013

Yes, I don't like the 'local' prefix too.  How about '__dictlookup__'?
It's just more self-describing.


On 2013-09-09, at 2:23 PM, Jan Kaliszewski <zuo at chopin.edu.pl> wrote:

> Is '__locallookup__' a really good name? In Python, *local* -- especially in context of *lookups* -- usually associates with locals() i.e. a namespace of a function/method execution frame or a namespace of a class, during *definition* of that class... So '__locallookup__' can be confusing.
> Why not just '__getclassattribute__' or '__classlookup__', or '__classattribute__'...?
> Cheers.
> *j
> _______________________________________________
> Python-Dev mailing list
> Python-Dev at python.org
> https://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe: https://mail.python.org/mailman/options/python-dev/yselivanov.ml%40gmail.com

More information about the Python-Dev mailing list