[Python-Dev] PEP 455: TransformDict

Antoine Pitrou solipsis at pitrou.net
Sat Sep 14 23:58:44 CEST 2013

On Sun, 15 Sep 2013 00:55:35 +0300
Serhiy Storchaka <storchaka at gmail.com> wrote:
> 14.09.13 20:41, Antoine Pitrou написав(ла):
> > No good reason. What's the name? transform_func?
> transform_func looks... truncated. Why not transform_function or trans_func?

The stdlib commonly uses "func" rather than "function". For example
"functools", where partial has an attribute named "func".
I suppose it's like "int" vs. "integer".



More information about the Python-Dev mailing list