[Python-Dev] PEP 471 -- os.scandir() function -- a better and faster directory iterator

Tim Delaney timothy.c.delaney at gmail.com
Fri Jun 27 01:36:28 CEST 2014

On 27 June 2014 09:28, MRAB <python at mrabarnett.plus.com> wrote:

> Personally, I'd prefer the name 'iterdir' because it emphasises that
> it's an iterator.

Exactly what I was going to post (with the added note that thee's an
obvious symmetry with listdir).

+1 for iterdir rather than scandir

Other than that:

+1 for adding scandir to the stdlib
-1 for windows_wildcard (it would be an attractive nuisance to write
windows-only code)

Tim Delaney
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-dev/attachments/20140627/173eb80f/attachment.html>

More information about the Python-Dev mailing list