[Python-Dev] Workflow blocked on the 3.6 because of AppVeyor; who owns the AppVeyor project?

Victor Stinner vstinner at redhat.com
Wed Sep 5 05:52:50 EDT 2018


It's no longer possible to merge any change in the 3.6 branch of
CPython, because the AppVeyor job fails:

It seems like AppVeyor has a build cache and this cache is outdated. I
tried to use the REST API but I'm not allowed to invalidate the cache:
even the most basic REST API query (list my own roles) fails with:

{"message":"You do not have required permissions to perform this action."}

Who ows the "python" AppVeyor project? Can someone please give me the
administrator permission on this project, so I will be able to invalid
the build cache?

Moreover, would it be possible to give me the administrator permission
on the CPython GitHub project, so I would be able to mark the AppVeyor
as optional until the issue is solved (to unblock the workflow at
least)? I promise I will not mess up the Python project ;-)

Thanks in advance,

More information about the Python-Dev mailing list