[Python-Dev] Workflow blocked on the 3.6 because of AppVeyor; who owns the AppVeyor project?

Paul Moore p.f.moore at gmail.com
Wed Sep 5 06:03:48 EDT 2018

On Wed, 5 Sep 2018 at 10:55, Victor Stinner <vstinner at redhat.com> wrote:
> Hi,
> It's no longer possible to merge any change in the 3.6 branch of
> CPython, because the AppVeyor job fails:
> https://bugs.python.org/issue34575
> It seems like AppVeyor has a build cache and this cache is outdated. I
> tried to use the REST API but I'm not allowed to invalidate the cache:
> even the most basic REST API query (list my own roles) fails with:
> {"message":"You do not have required permissions to perform this action."}
> Who ows the "python" AppVeyor project? Can someone please give me the
> administrator permission on this project, so I will be able to invalid
> the build cache?
> Moreover, would it be possible to give me the administrator permission
> on the CPython GitHub project, so I would be able to mark the AppVeyor
> as optional until the issue is solved (to unblock the workflow at
> least)? I promise I will not mess up the Python project ;-)

I don't appear to have admin rights on Appveyor either. Also, there
doesn't appear to be an appveyor.yml file in the CPython repository,
so I'm not clear how the build process has been configured. Does
anyone have that information? (And I'd strongly recommend that if
we're somehow configuring the builds via the Appveyor UI, we move to
using a config file like we do for Travis, so that diagnosis and fixes
can be done without needing to access the Appveyor admin interface...)


More information about the Python-Dev mailing list