python-ldap + webware + solaris odd problem

Joe Pasko fightplatetectonics at
Fri Mar 4 21:03:14 CET 2005

Hi All, 

I'm seeing a weird problem using python-ldap under solaris with
webware as the app-server.

The python-ldap modules works fine under Solaris and linux if run from
the command line, and fine as a .cgi under apache. When running under
webware on Solaris,  I'm getting a can't connect to ldap server error.

I've run this same code under webware on linux, and it works fine.

One of my first thoughts is solaris's linker, but I've added the
openldap lib dir to LD_LIBRARY_PATH and restarted the
same result.

Has anyone run into this?

I've tried  solaris 8, solaris 10, and suse 9, all with the same
results. Works under linux under webware, pukes on the bind under

The traceback is:

File "/usr/local/lib/python2.2/site-packages/ldap/", line
183, in bind
    return self.simple_bind(who,cred)
  File "/usr/local/lib/python2.2/site-packages/ldap/",
line 169, in simple_bind
    return self._ldap_call(self._l.simple_bind,who,cred,serverctrls,clientctrls)
  File "/usr/local/lib/python2.2/site-packages/ldap/",
line 94, in _ldap_call
    result = func(*args,**kwargs)
SERVER_DOWN: {'desc': "Can't contact LDAP server"}

The servlet code is:


More information about the python-ldap mailing list