python2.1 and RedHat7.1

Garry Hodgson garry at sage.att.com
Wed Jun 27 19:06:39 CEST 2001


"Robert J. Peters" wrote:
> 
> Michael Ackerman <ack at nethere.com> writes:
> 
> > I tried to install the python2.1 rpm for RedHat7.0 on my 7.1 system
> > but got a "failed dependency" message saying that it wants:
> >     libcrypto.so.0.9.6, libssl.so.0.9.6
> > But these files are present, in /usr/lib. So what's going on?
> > Any help will be appreciated.
> 
> This was my situation exactly yesterday, when I was trying to install
> python2.1 from the rpm onto a RedHat 7.1 system, and got the same
> error messages... yet searching in /usr/lib showed the libs were in
> fact there:
> 
> [hume 16:14 284]% ls /usr/lib | grep ssl
> libssl.a
> libssl.so@
> libssl.so.0.9.6*
> libssl.so.1@
> [hume 16:14 285]% ls /usr/lib | grep crypto
> libcrypto.a
> libcrypto.so@
> libcrypto.so.0.9.6*
> libcrypto.so.1@
> 
> So, I poked around with and "rpm --help" and decided to try the
> install with the "--nodeps" option (i.e.
> 
>     rpm --nodeps --install <package>.rpm
> 
> ) to tell rpm ignore whatever failed dependencies it discovered, since
> the necessary libraries were plainly present... that command worked
> without error, and the installation seems to be working fine (at least
> for the first 24 hours...).

an alternate way that worked for me is to get the src rpm and do:

	rpm --rebuild

to rebuild the rpms, then installed them.

-- 
Garry Hodgson                   sometimes we ride on your horses
Senior Hacker                   sometimes we walk alone
Software Innovation Services    sometimes the songs that we hear
AT&T Labs                       are just songs of our own
garry at sage.att.com



More information about the Python-list mailing list