Emacs python-mode,py-pychecker-run problem.

Pedro Werneck pedro.werneck at bol.com.br
Mon Aug 18 15:08:44 CEST 2003


Hi,

I don't know if I should ask this here or on an emacs group/list. If I choose wrong, please forgive me.

I am trying to run pychecker on the current buffer on python-mode using the py-pychecker-run command, but it fails with the "Symbol's function definition is void: read-shell-command" error. I don't know elisp, but seems this is the point where the error occurs:

;; Pychecker
(defun py-pychecker-run (command)
  "*Run pychecker (default on the file currently visited)."
  (interactive
   (let ((default
           (format "%s %s %s" py-pychecker-command
		   (mapconcat 'identity py-pychecker-command-args " ")
		   (buffer-file-name)))
	 (last (when py-pychecker-history
		 (let* ((lastcmd (car py-pychecker-history))
			(cmd (cdr (reverse (split-string lastcmd))))
			(newcmd (reverse (cons (buffer-file-name) cmd))))
		   (mapconcat 'identity newcmd " ")))))

     (list
      (read-shell-command "Run pychecker like this: "
                          (if last
			      last
			    default)
                          'py-pychecker-history))))
  (save-some-buffers (not py-ask-about-save) nil)
  (compile-internal command "No more errors"))

;

And as far as I can understand, seems like my emacs doesn't have the read-shell-command function. If I try to execute or get help on it, it doesn't exist, but there's a shell-command. I tried to change but I still get erros. Is  my assumption right ? How can I solve it ? 

I am using Gnu Emacs 21.2.2 (Slackware Linux 8.1, full install), python-mode version 4.34 and pychecker 0.8.12

Thanks for any help

Pedro





More information about the Python-list mailing list