Python bytecode compatibility between interpreter versions

Skip Montanaro skip at pobox.com
Sun Mar 21 18:59:49 CET 2004


    Jon> Anyway, we can at least count on the fact that a .pyc compiled by a
    Jon> particular Python version (say, Python 2.1.1) on one platform (say,
    Jon> Mac), will run on another platform (say, Solaris) as long as the
    Jon> interpreter has the same minor version (say, Python 2.1.0).

Yup.  I believe there were some problems between 32- and 64-bit platforms
ages ago, but they've been resolved.

Skip




More information about the Python-list mailing list