[PythonCAD] Moving objects breaks dimensions

Wilbert Knol w.knol at niwa.co.nz
Sat Feb 11 02:43:08 CET 2006

> >> Test driving this revision (as well as previous revisions) I find
> >> that moving objects that have dimensions attached to them doesn't
> >> work properly. The end points of the dimension line get moved, along
> >> with the object (a rectangle) but the center of the dim. line along
> >> with the value stays behind.
> >
> >This behavior is by design, but it may not be what is expected. Moving
> > a dimension is really just moving the dimension text DimString
> > entities, so things have been coded so that moving the points in some
> > entity does not automagically move the DimStrings of associated
> > dimensions. It could be time to reassess this decision ...
> fwiw, autocad doesn't try to make any association between dimensions and
> entities.  If you want to move an entity and related dimensions, you
> just select them all together.

Agreed, and that's exactly what I did. I drew a box around the lot and tried 
to shift it.

It worked...except for the dimension text, and the centre part of the 
dimension line, which stayed put along with the dim. text. The arrows 
rubber-banded with the object to the new location. 

I must admit I was somewhat taken aback :-)


More information about the PythonCAD mailing list