[Pythonmac-SIG] bundlebuilder --standalone not working

Just van Rossum just at letterror.com
Tue Sep 2 21:06:38 EDT 2003

Bob Swerdlow wrote:

> However, when I run python buildapp.py --standalone build it
> generates a bunch of warnings (I've appended them below) and when I
> run the application, I get this error: from xml.sax import saxutils
> ImportError: No module named sax

This is most likely caused by PyXML's _xmlplus hack. Try to add
--package=_xmlplus. If that doesn't work, you could tweak your install
by removing the original xml package, and rename _xmlplus to xml.

> When I look in the application package, the Frameworks directory
> includes the Python.framework/Versions/2.3 directory, but it does NOT
> have the lib subdirectory. 

Correct, only the bare necessities. Everything needed from the library
is in Contents/Resources/Modules.zip and

> I tried copying in that directory
> manually, but the application still could not find it - presumably
> because there is some kind of path that needs to be set for it.

Contents/Resources/ is on sys.path, so if needed you can copy stuff
there. But I'd rather find a way to let bundlebuilder do what you need.

> So, how do I get --standalone to find the rest of these modules and
> build a complete application?

Let me know if the "--package=_xmlplus" thing worked.


More information about the Pythonmac-SIG mailing list