[Pythonmac-SIG] libpython for 2.4.1 on OSX 10.3

Eli Stevens (WG.c) listsub at wickedgrey.com
Tue Aug 16 21:36:17 CEST 2005


List newbie here, sorry if this is a FAQ (I don't see it in the cached 
copy of the FAQ, and the wiki seems to be down).

I'm trying to get Inline::Python (allows python to be called from perl 
with very little glue) working on OSX 10.3.  I have installed the 
framework build of 2.4.1 and am able to use it, run scripts, etc.

Inline (the base for Inline::Python, Inline::C, etc.) seemd to install 
fine.  When I installed Inline::Python, however, it asked me:

> $ perl Makefile.PL 
> Found these python executables on your PATH:
> 1. /usr/local/bin/python
> 2. /usr/bin/python
> Use which? [1] 
> Using /usr/local/bin/python
> This python's configuration files are messed up. You'll have have to
> answer the questions yourself. Here is what Python said:
>    Extra Libs:  None
>    Python Library:  None/config/None
>    Include Path:    None
>         1. LIBS option. I need to know what extra libraries, if any,  
>            are required by this build of python. I recommend this:
>            None
> Enter extra libraries (e.g. -lfoo -lbar) [None] 
>         2. LIBRARY option. The location of the python library. 
>            Inline::Python needs to link against it to use Python.
>         Here are the libraries I know about:
> Which? Or enter another. [1] /Library/Frameworks/Python.framework/Versions/2.4/Python            
>         3. INCLUDE option. The location of the python include files.
>            Inline::Python needs these to compile.
>         Here are the locations I know about:
> Which? Or enter another. [1] /Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/

Now, all of my entries above (everything after [1]) are just guesses 
that don't seem to work (I've tried fiddling with the things I gave it, 
and the include dir seems to be correct).  When I run something that 
uses Inline, I get the following:

> $ perl test.pl 
> Can't make loaded symbols global on this platform while loading /Library/Perl//darwin/auto/Inline/Python/Python.bundle at /Library/Perl//darwin/DynaLoader.pm line 229.
> dyld: /usr/local/bin/perl Undefined symbols:
> _PyCallable_Check
> _PyClass_Type
...much removed...
> __Py_NoneStruct
> __Py_TrueStruct
> Failed to autogenerate /Users/elis/code/play/perl/_Inline/config.
>  at test.pl line 13
> BEGIN failed--compilation aborted at test.pl line 13.

In my searching the closest answer I have found is "use -framwork 
instead", but I'm not really in control of the code (and I'd rather not 
start munging around inside Inline internals if I don't have to).  What 
should I do?  Is there a libpython laying around somewhere that I am 
unable to locate?  Is there an easy way to build it?

Thanks for any help,

More information about the Pythonmac-SIG mailing list