[Pythonmac-SIG] libpython for 2.4.1 on OSX 10.3

Bob Ippolito bob at redivi.com
Tue Aug 16 22:05:05 CEST 2005

On Aug 16, 2005, at 9:36 AM, Eli Stevens (WG.c) wrote:

> I'm trying to get Inline::Python (allows python to be called from perl
> with very little glue) working on OSX 10.3.  I have installed the
> framework build of 2.4.1 and am able to use it, run scripts, etc.

Sounds like their build scripts are broken.  The correct way to  
determine how to link to Python is to ask Python (via distutils, or  
read its Makefile directly).  You should talk to them about this  

However, the quick & dirty workaround would to be to do something  
like this:

sudo ln -s /Library/Frameworks/Python.framework/Versions/2.4/include/ 
python2.4 /usr/local/include/python2.4
sudo ln -s /Library/Frameworks/Python.framework/Versions/2.4/Python / 

It should be able to use -lpython2.4 at that point, and might even  
find the include files where it expects to find them.


More information about the Pythonmac-SIG mailing list