[Pythonmac-SIG] python make failing: "ImportError: No module named MacOS"

OpenMacNews OpenMacNews at speakeasy.net
Sat Mar 19 23:34:19 CET 2005

hi bob,

>> any suggestions as to what's broken here?
> Works here, with 2.4.1c1 anyway.
> but there have been no relevant  changes that I know of.

i dropeed back and tried it with c1 as well ... same prob 4 me.


> Most of the arguments you specify to configure  are already
> on by default or have no effect.  The --prefix argument has  no effect, the
> symlinks are hardcoded to be installed to  /usr/local/bin, and the framework
> contains everything else.

well, that's particularly annoying ...

then why offer the --prefix arg in the first place?  just for NON-framework 

> I'm not  totally sure that enable-toolbox-glue is
> on by default, but I think it  is.  I used it anyway:
> % mkdir -p ~/src/Python-2.4.1c1/_panther
> % cd ~/src/Python-2.4.1c1/_panther
> % ../configure \
>      --enable-toolbox-glue \
>      --enable-framework=/Users/bob/python-2.4.1c1/Frameworks
> % make
> % sudo make frameworkinstall
> worked fine for me.

ok, so something's missing on my system ... which is particularly odd since its 
a clean/complete install.

hmmmm ....

anyone else, perhaps with ideas?  or should i take this over the the dev list?



More information about the Pythonmac-SIG mailing list