[Pythonmac-SIG] python 2.4.2 source builds 2.4.1?

Kevin Walzer sw at wordtech-software.com
Mon Jan 9 06:29:55 CET 2006

Hash: SHA1

Samuel M. Smith wrote:
> I next tried removing the old 2.4.1 installation by changing the name  
> of the directory
> /library/frameworks/python.framework/versions/2.4 to 2.4a
> I then did a ./configure and make
> I tried to run ./python.exe and got the following error
> AlBook:/install/python/macpython/python2.4.2/python-2.4.2 smithsm$ ./ 
> python.exe
> dyld: Library not loaded: /Library/Frameworks/Python.framework/ 
> Versions/2.4/Python
>    Referenced from: /Install/Python/MacPython/Python2.4.2/ 
> Python-2.4.2/./python.exe
>    Reason: image not found
> Trace/BPT trap
> so apparently I can't run the python.exe without the framework fully  
> installed so I did
> sudo make install
> and got this error
> Framework build: use "make frameworkinstall" in stead of "make install"
> make: *** [altbininstall] Error 1
> so I tried
> sudo make frameworkinstall
> and this worked.
> So the real way to build 2.4.2 is first removed any previous 2.4.x  
> builds then
> run
> ./configure --enable-framework
> make
> sudo make frameworkinstall
> this is different from every instruction I have seen. Nobody has ever  
> said use make framworkinstall.
> So either everyone else is wrong or I am missing something important.
Aren't the instructions about the "makeframework install" somewhere in
the Python source tree (a README or something like that)? I remember
running into this issue with 2.4.2, then consulting docs somewhere in
the code package I downloaded, then trying again successfully. The
buildd process even rebuilt all the packages I had installed in the
site-packages directory. Unexpected, but not an issue.

- --

Kevin Walzer, PhD
WordTech Software - "Tame the Terminal"
sw at wordtech-software.com
Version: GnuPG v1.4.1 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Pythonmac-SIG mailing list