[Pythonmac-SIG] Getting cantera to run

Tavis tavis at naughtylittlemonkey.org
Sun Feb 3 22:11:58 CET 2008

I've been struggling to get cantera to run on my mac. I have OX  
10.4.11 with Python 2.5.1 installed and numarray 1.5.2. Importing  
numarray in python doesn't generate any errors, so I assume it to be  
working. I ran a Cantera 1.6 binary and it seemed to install ok, but  
I can't get python to recognize it. I added /Applications/Cantera/bin  
to my path and I ran the setup_cantera file, though I had to run it  
line by line in terminal since I couldn't get it to work as a shell  
script (maybe I should have added .sh to the file? Thats a question  
for another day). Whenever i try "import cantera" at a python prompt,  
i get
Traceback (most recent call last):
   File "<stdin>", line 1, in <module>
ImportError: No module named cantera
Would I be better off trying to compile cantera 1.7 for the source  
files? Any other suggestions. 

More information about the Pythonmac-SIG mailing list