[Spambayes] Outlook problem

Tim Peters tim.peters at gmail.com
Thu Sep 30 06:14:00 CEST 2004

[Tony Meyer]
> This is a known bug, unfortunately, with an unknown solution.  The relevant
> tracker is:
> [ 785089 ] Can't move items from Advanced Find
> <http://sf.net/tracker/?group_id=61702&atid=498103&func=detail&aid=785089>

>> Why should this be, and is there a work-around?

Ah, Windows -- it's such a delight <wink>.

> Unfortunately, we don't know the answer to the former.  It's very strange,
> because SpamBayes isn't involved in that move at all

Indeed!  We don't hook anything even conceivably relevant except
Outlook's add-to-folder event.

> (the problems occurs even with folders that SpamBayes knows nothing about).
> What version of Outlook are you using?  The two confirmed cases of this are
> with Outlook 2002 SP2, and I wonder if this is an Outlook bug that we are
> running into (which might be fixed in other versions of Outlook).

Sounds likely to me.  I just tried it on OL 2003 SP1, Win XP Pro SP2. 
No problems of any kind dragging from the Advanced Find window.  OTOH,
I'm running SpamBayes from source and haven't updated in about a
month.  But then nothing interesting has changed in that month anyway.

> To work around the problem, you can right-click the message(s) you want to
> move, choose "Move to folder", and specify the folder that way.  Annoying, I
> will admit, but I'm really not sure how to go about solving this bug.

Alas, it looks, feels, and smells like another Outlook bug.  Has
anyone looked in their SpamBayes log file for "funny messages" near
the time of the failing drag attempt?  Since it doesn't fail for me,
it's not surprising that my log doesn't show anything odd when I try.

More information about the Spambayes mailing list