[Tutor] sockets broken on New Install???

Sheila King sheila@thinkspot.net
Thu, 16 Aug 2001 08:41:01 -0700

OK, so I *thought* I'd upgrade from 2.0 to 2.1.1. I have Linux host with
shell account for my web site. I find my way around Linux with
difficulty. (I'm really a Windows person <hangs head in shame>.)

So, I got Python-2.1.1.tgz on my site, unzipped it, and went to the top
directory and types:

./configure --prefix=/big/dom/xthinkspot

(that's the path to my top level directory)

And that looked fine.

Then I typed:
make install

and a bunch of stuff happened. And I now have a python2.1* executable in
the /big/dom/xthinkspot/bin 
directory. And the python* points to it. (Fortunately, my python2.0* is
still there, unaffected and functioning.)

And all the Lib modules seem to have been copied to

BUT when I ran the make test, I got error messages that indicate
something is seriously wrong.

119 tests OK.
4 tests failed: test___all__ test_asynchat test_socket test_sundry
16 tests skipped: test_al test_cd test_cl test_dl test_gl test_imgfile
test_largefile test_linuxaudiodev test_minidom test_nis test_pyexpat
test_sax test_socketserver test_sunaudiodev test_winreg test_winsound
make: *** [test] Error 1

Having sockets not work is a real problem.

I brought up the 2.1.1 interpreter for an interactive session. I could
import several different modules, such as os and string, but when I
tried to import smtplib I get this error message:

>>> import smtplib
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/big/dom/xthinkspot/lib/python2.1/smtplib.py", line 42, in ?
    import socket
  File "/big/dom/xthinkspot/lib/python2.1/socket.py", line 41, in ?
    from _socket import *
ImportError: /big/dom/xthinkspot/lib/python2.1/lib-dynload/_socket.so:
 symbol: ERR_load_RSAREF_strings

We just had a system upgrade last night. Went from an earlier Red Hat
Linux to RH 6.2 and glibc went from glibc-2.0.7 to glibc-2.1.3, but I
don't see why this should matter, since I'm recompiling and relinking
from scratch?

Please, help?

Sheila King

Sheila King