[Tutor] problem with matplot

nephish nephish at xit.net
Tue Sep 20 16:55:46 CEST 2005

hey there,
anyone have any luck getting up and running with matplot-lib on debian?
from the website, i followed the instructions to get it with apt. but 
something is messed up in the dependencies.

i get this
import pylab

Traceback (most recent call last):
  File "<pyshell#0>", line 1, in -toplevel-
    import pylab
  File "/usr/lib/python2.3/site-packages/pylab.py", line 1, in -toplevel-
    from matplotlib.pylab import *
  File "/usr/lib/python2.3/site-packages/matplotlib/pylab.py", line 198, 
in -toplevel-
    from axes import Axes, PolarAxes
  File "/usr/lib/python2.3/site-packages/matplotlib/axes.py", line 13, 
in -toplevel-
    from artist import Artist, setp
  File "/usr/lib/python2.3/site-packages/matplotlib/artist.py", line 4, 
in -toplevel-
    from transforms import identity_transform
  File "/usr/lib/python2.3/site-packages/matplotlib/transforms.py", line 
189, in -toplevel-
    from _transforms import Value, Point, Interval, Bbox, Affine
  File "/usr/lib/python2.3/site-packages/matplotlib/_transforms.py", 
line 11, in -toplevel-
    from matplotlib._nc_transforms import *
ImportError: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found 
(required by /usr/lib/python2.3/site-packages/matplotlib/_nc_transforms.so)

i have already installed libstdc++6, and i dont really know what version 
GLIBCXX_3.4.4 means.

anyone have an idea?


More information about the Tutor mailing list