[AstroPy] how to initialize Ureka?

Grigoris Maravelias gr.maravelias at gmail.com
Mon Dec 8 07:41:39 EST 2014

Hi Hang!

I have managed to install Ureka successfully (in Debian 3.2 32bit system).

I see that you installed Ureka as root (?). Ureka does not need root
privileges so perhaps it does not start if you are logged in as a
different user than the user which was used to install Ureka.

If not true then I would double check the bashrc/cshrc files.

On 12/08/2014 06:15 AM, gonghang.naoc wrote:
> Hi all,
> It seems everything has been done. However I have tried many times and
> can not install or initialize it successfully.
> I follow the installing method here
> (http://ssb.stsci.edu/ureka/dev/docs/installation.html)
> First I download Ureka_linux-rhe5_64_1.4.1.1. tar.gz  from
> http://ssb.stsci.edu/ureka/
> <http://ssb.stsci.edu/ureka/> 
> and extract it to /usr/Ureka .
> [root at localhost bin]# sh  /usr/Ureka/bin/ur_normalize
> Normalizing Ureka found in /usr/Ureka
> Updating library references...
> ..Ureka core
> ..IRAF
> ..variant: common
> Updating symbolic links...
> ..variant: common
> Updating shebang lines...
> It is possible to have multiple copies of Ureka on your system.  To 
> distinguish them, you give each a name.  You can use this name later
> with ur_setup to choose which copy of Ureka you want to use.
> You have no existing Ureka installs configured
> The name can only contain letters, digits, underline and dash.
> Enter an installation name:
> ureka
> Ureka needs to add a few lines to your login scripts.  It can
> check if they are already there and automatically add them if
> needed.  Answer yes unless you know a particular reason to
> answer no.
> Automatically configure login scripts?  Enter yes or no [yes]: y
> WARNING - y is not a valid response
> Automatically configure login scripts?  Enter yes or no [yes]: yes
> ======================================================================
> Ureka is installed.  Log in a new terminal window and type the command
>     ur_setup
> or
>     ur_setup common ureka
> to select your Ureka environment.  'ur_setup -h' will show some help.
> After I run ur_test,  if I run ur_setup in the same window, ur_setup 
> can be recognized.  No  'ur_setup: command not found...'  will appear. 
> If I continue in the same window, for example, I run 'ecl',  it will 
> let me configure the variables.
> How to configure the variables?
> And if I open a new terminal window,  ur_setup will not be recognized.
> Anybody is  running Ureka successfully?  Who knows how to solve the
> problem above?
> Thank you very much.
> best
> hang
> _______________________________________________
> AstroPy mailing list
> AstroPy at scipy.org
> http://mail.scipy.org/mailman/listinfo/astropy

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/astropy/attachments/20141208/9337b5d0/attachment.html>

More information about the AstroPy mailing list