[Distutils] buildout: bootstrap.py in 1.5.0b1 + python 2.5

Rodrigo Moraes rodrigo.moraes at gmail.com
Fri Apr 30 17:26:45 CEST 2010

I'm facing a problem running the bootstrap.py from buildout 1.5.0b1.
The errors are pasted here:


This error occurs only when I use Python 2.5; with 2.6 it works fine.
Also it happens even if i set the flag --distribute. So for the time
being I'm using the bootstrap from 1.4.3 on python 2.5, as it works

I tried to debug it but I'm not familiar with the libraries and had no
success. Could anybody please confirm that it is not working with
Python 2.5 so that I know that the problem is not in my environment?

thank you,

More information about the Distutils-SIG mailing list